Posts Tagged‘theme’

New Server, New Theme, New Beginnings.

On the surface this blog hasn’t changed that much. The right hand column had shifted around a bit as I added and subtracted various bits of social integration but for the most part the rest of the site remained largely static. Primarily this was due to laziness on my part as whilst I always wanted to revamp it I could just never find the motivation, nor the right design, to spur me on. However after a long night spent perusing various WordPress theme sites I eventually came across one I liked but it was a paid one and although I’m not one to shy away from paying people for their work it’s always something of a barrier. I kept the page open in Chrome and told myself that when it came time to move servers that’d be the time I’d make the switch.

And yesterday I did.

The Code Behind The Refined Geek

My previous provider, BurstNET, whilst being quite amazing at the start slowly started to go downhill as of late. Since I’d been having a lot of issues, mostly of my own doing, I had enlisted Pingdom to track my uptime and the number of reports I got started to trend upwards. For the most part it didn’t affect me too much as most of the outages happened outside my prime time however it’s never fun to wake up to an inbox full of alerts so I decided it was time to shift over to a new provider. I had had my eye on Digital Ocean for a while as they provide SSD backed VPSs, something which I had investigated last year but was unable to find at a reasonable price. Plus their plans are extraordinarily cheap for what you get with this site coming to you via their $20/month plan. Set up was a breeze too, even though it seems every provider has their own set of quirks built into their Ubuntu images.

The new theme is BlogTime¬†¬†from ThemeForest and I chose it precisely because it’s the only one I could find that emulates the style you get when you login to WordPress.com (with those big featured images at the top with a nice flat layout). The widgets he provides with the theme unfortunately don’t seem to work, at least not in the way that’s advertised, so I had to spend some time wrestling with the Facebook and Twitter widget APIs to get them looking semi-decent on the sidebar. Thankfully it seems the “dark” theme on both sites seems to match the background on here quite well otherwise I would’ve had to do a whole bunch of custom CSS stuff that I just wasn’t in the mood for last night. Probably the coolest thing about this theme is that it automatically resizes itself depending on what kind of device you have so this blog should look pretty much the same no matter how you’re viewing it.

I also took the opportunity to try and set up caching again and whilst it appeared to work great last night upon attempting to load my site this morning I found that I was greeted with an empty response back. Logging into the WordPress dashboard directly seemed to solve this but I’m not quite sure what caused W3 Total Cache to cause my site to serve nothing for the better part of 5 hours. For the moment I’ve disabled it as the site appears to be running quite fine without it but I’ll probably attempt to get one of them running again in the future as when they’re working they really are quite good.

Does this change in face mean there’s going to be a radical change in what this site is about? I’m not intending to as whilst my traffic has been flagging of late (and why that is I couldn’t tell you) this was more a revamp that was long overdue. I’d changed servers nearly once a year however I had not once changed the theme (well unless you count the Ponies incident) and it was starting to get a little stale, especially considering it seemed to be the theme of choice for a multitude of other tech blogs I visited. So really all that’s changed is the look and the location that this blog is coming to you from, everything else is pretty much the same, for better or for worse.